Проблема с DLE при установке на сервер

19 Окт 2010  |  Автор:  |  Рубрика: Сайтостроение  | 

При установке сайта на DLE на сервер выскочила ошибка следующего плана:

Warning: equire_once(/home/888/domains/888.com/public_html/portal/language/Russian/adminpanel.lng): failed to open stream: No such file or directory in /home/888/domains/888.com/public_html/portal/install.php on line 14 Fatal error: require_once(): Failed opening required ‘/home/888/domains/888.com/public_html/portal/language/Russian/adminpanel.lng’ (include_path=’.:/usr/local/lib/php’) in /home/888/domains/888.com/public_html/portal/install.php on line 14

Естественно что на Denwere все работало до заливки.
Ну и пошел я гуглить… каких советов только ни читал: и переустановить двиг, и снести все с сервера, и поиграться с правами доступа и т.д. и т.п.

Решение оказалось совсем простым. Посмотрел на ошибку, увидел путь (language/Russian/adminpanel.lng) и ахнул, это вам не саркома кости у собак, а гораздо проще. При заливке на сервер фтп-клиент все названия папок и файлов переводит в нижний регистр, а DLE ищет Russian.

Решение: изменить название папки russian по адресу language/Russian на Russian и все заработает! Вуаля!
Удачи.

google.com bobrdobr.ru del.icio.us technorati.com linkstore.ru news2.ru rumarkz.ru memori.ru moemesto.ru

Отзывов: 2 | Нам важно ваше мнение!

  1. Александр Чибисов  |  20 Дек 2010 в 17:49 #

    ТОЧНО, вот я дурень, блин,гуглю второй день, у вордпреса таких проблем небыло!, вобщем СПАСИБО!

    Александр Чибисов - Gravatar
  2. TRTR  |  14 Июн 2011 в 23:35 #

    СПАСИБО ПОМОГ

    TRTR - Gravatar